• unk

Настройка WireGuard на Mikrotik

Цель сделать доступ до домашнего роутера Mikrotik и сетей за ним через VPN WireGuard.


Mikrotik должен иметь прошивку не ниже 7 ревизии.


Заходим через WinBox на роутер, открываем терминал



Создаем интерфейс:


/interface wireguard add listen-port=51820 mtu=1420 name=wireguard1


Просмотр ключей (пригодится дальше):


/interface wireguard print



Добавляем адрес на созданный ранее интерфейс:


/ip address add address=10.0.0.1/24 interface=wireguard1 network=10.0.0.0


Добавляем разрешающее правило в firewall:


/ip firewall filter add action=accept chain=input comment=«Accept WireGuard» dst-port=51820 log=yes log-prefix=WG: protocol=udp


Конфигурируем клиента для подключения из вне, через родное приложение WireGuard:


Сюда добавляем публичный ключ (public-key), который был на втором шаге.

Endpont это белый (внешний) адрес Mikrotik.


Далее в консоли добавляем Peer:


/interface wireguard peers add allowed-address=10.0.0.2/32 interface=wireguard1 persistent-keepalive=20 public-key=«CLIENT-PUBLICKEY»


CLIENT-PUBLICKEY - это публичный ключ от клиента, из предыдущего шага. На скрине ниже он подчеркнут.

Создаем правило, разрешающее доступ из вне к нашему Mikrotik только из подсети WireGuard. Вкладка IP -> Firewall.

Во вкладке Action ставим accept и применяем.


Важный момент, о котором почти нигде не пишут - нужно поднять правила наверх, над запрещающими, иначе работать не будет.



На этом настройка завершена и все работает.

16 просмотров0 комментариев

Недавние посты

Смотреть все